GOOGLE’S 9 MAJOR RANKING SIGNALS

What they are and how to check your site against them
Introduction

It's no secret that a top Google ranking is made up of 200+ components, or “ranking signals”. But while it's definitely useful to know what all of those are, the entire list is a very time-consuming (and frankly, a little depressing) read. It's somewhat vague in terms of the impact of each individual factor, and all of those things don't seem doable if you try to get each one right. With the news about another Google update or algorithm change rolling out every other week, how can anyone keep up, ever?

But long-time SEO-ers have their tricks of the trade. The thing is, the 200+ ingredients in Google's recipe aren't all equally important. In the cheat sheet below, you'll find the 9 most important ranking signals that multiple studies have found to have the biggest impact on rankings today. The cheat sheet is based on our own research at SEO PowerSuite, as well as this year's ranking factors studies by SearchMetrics and Backlinko.

Equipment

Here are the tools you'll need to measure and optimize for the 9 ranking signals in this guide.

1. Google Search Console
2. SEO PowerSuite (Download free | Order license)
Google's 9 major ranking signals

Contents

Backlinks 4
On-page SEO 10
User Experience & Trust 13
Technical SEO factors 16
1. Number of backlinks and linking domains (18%)

A few years ago, link count was perhaps the major quality signal for Google. Over time, the search engine has learned to identify the so-called link schemes, or low quality links created solely for the purpose of obtaining higher rankings. Since then, it's often said that quality comes before quantity for Google - but this is only partly true. The number of pages and domains linking to a site still has a massive impact on your ranking potential; it's just that you can't afford to have any low-quality links in your profile anymore.

In several of its patents, Google suggests that a site's overall link score (arguably the biggest ranking signal) is made up by individual quality scores passed on to it by every incoming link. That literally means that more links will result in a higher score – as long as they aren't link schemes, of course.

It's also important to note that links coming from the same domain (especially site-wide links) carry little weight; Google will often only count one of those links when evaluating your link profile.

Checking on your top SEO competitors’ link profiles is a good starting point to understand what kind of link scores you are competing against, and how much work is required for you to catch up.

How to check In SEO SpyGlass, create a project for your site. Go to the Domain Comparison module and add the domains of your major competitors, one by one, and see how you compare to competitors’ link profiles. Total Backlinks and Total Linking Domains should give you a good idea on how much improvement your link profile may need, quantity-wise.
How to improve

To find quality link prospects and start building new links, launch SEO PowerSuite's LinkAssistant. Create a project and click Look for prospects, selecting a search method you'd like to use (you can repeat the process for as many methods as you like). Once you're done with prospect research, you should have a list of potential link partners in your project along with their email addresses for outreach.

When you've singled out top prospects, you can reach out to them right from LinkAssistant. Right-click a contact (or several contacts, if you'll be sending them a similar message), and click Send email to selected prospects. In your email, feel free to either put up a message of your own or use some of the ready-made email templates, depending on the link building technique you're using. You can check for replies and manage your correspondence with prospects in the Email module.

2. Link authority (14%)

The talk about link quality has been on for years, and most SEO-ers agree it remains one of the strongest ranking signals for Google. While high quality links can boost your site's link score (and therefore rankings), lower quality backlinks can get your site penalized (and even out of the SERP completely).

For the latter not to happen, make sure you run regular link audits so you can spot any dangerous links early and have them removed in time. To acquire more high-authority links, it's a good idea to look at your competitors' profile and try to win some of their links for your own site.

How to check

Launch SEO PowerSuite's SEO SpyGlass and create a project for your site. Once the app has collected the list of your site's backlinks, switch to the Backlinks dashboard, select all those links and click Update Factors. Navigate to the Link penalty risk tab and click on the
header of the *Penalty Risk* column (this will sort the links by penalty risk). All links with a penalty risk above 30% are worth looking into — these can potentially be low quality links. All links with a penalty risk over 60% need your immediate attention as they are the ones that might get your link score below Google's low quality threshold, and have your site penalized as a result.

If you have just a few links that appear spammy or come from a low quality resource, it's best to reach out to the site owner asking them to take down the link.

If you don't hear back from them, or if you've got a substantial number of low quality links, disavowing them is your best option. Disavowing is basically telling Google to discard that link (or linking domain) when evaluating your link profile. To disavow backlinks, you’d need to put up a disavow file following certain syntax and formatting rules, and upload the file to Google Search Console.

You can create a disavow file right in SEO SpyGlass in a few clicks. To do that, select the links you’d like to disavow, right-click the selection, and hit *Disavow backlinks*. Most of the time, you’d want to disavow links on the domain level; so make sure you select *Entire domain* under *Disavow mode*. Then, go to *Preferences > Disavow/Blacklist backlinks* and hit *Export* to save the disavow file to your computer, and *upload it* to Google Search Console.
3. Link anchor text and its diversity (9%)

In general, you want your links to be coming from pages whose topic is similar to that of the page you’re optimizing. But how can Google identify relevance, exactly? Primarily, from the backlink's anchor text. The title of the backlink page can also help to tell what the page is about, although it is a much weaker signal than anchor text.

The concept of relevance is tightly linked to that of diversity. While your backlinks are expected to be semantically relevant to the topic of your page, it’s important to note that too similar anchor texts can get your under Google's Penguin penalty.

Understandably, there's no universally right ratio of different kinds of anchor text in your link profile. However, below you can find some averages to give you an idea of what a natural link profile typically looks like.
But just as it is with about anything in SEO, it’s best to rely on the link profiles of your top ranking competitors instead of the overall averages.

**How to check** In the SEO SpyGlass project you created for your own site, go to *Backlink Profile > Summary* for a breakdown of the most commonly used anchors (and keywords within those anchors). Do the same for the projects you've created for your top ranking competitors (you'll find them in the Project drop-down menu) to spot areas for improvement in terms of your links’ anchors.
**How to improve**

To change your current links' anchors, you’d need to reach out to webmasters that link to your site and ask them to make the change. To speed up the process, you can export your links from SEO SpyGlass by going to *File > Export*, and then import them to LinkAssistant in another click through *File > Import*.

Now, select the backlinks you’ve imported and hit **Update > Get Contact Email**. This way, you’ll be able to reach out to webmasters right from LinkAssistant and ask them to make any changes to the links’ anchor text (or contact them regarding any other matter).
4. Content relevance (19%)

Not surprisingly, your content has to be both original and relevant to the search phrase to rank well in Google. It doesn't even matter much what your site is about - starting from blog posts and on to e-commerce product pages, you need to bring unique value to the table if you are aiming for top rankings. Backlinko's [found](#) that **focused content that covers a single topic** significantly outperformed content that didn't cover a topic in-depth.

**How to check**  
In [WebSite Auditor](#), go to *Content Analysis > Page Audit* and pick a page you're about to optimize. Type in the keywords you're optimizing it for (try to think of as many synonyms as you can rather than just enter a keyword or two), and take a look at the on-page factors on the left. For any on-page factor that doesn't have a *Correct* status, switch to the *Competitors* tab to see which on-page tactics work best in your niche.

**How to improve**  
To edit your page's copy, go to *Content Analysis > Content Editor* in WebSite Auditor and feel free to make changes to your content right in the right-hand view. As you do that, you'll see the on-page factors on the left recalculate in real time so you know right away when you've reached your goals.
5. Content length (3%)

In its search quality guidelines, Google mentions the length of content as an important criterion for the page's quality – and therefore its rankings. Clearly, there's no ideal content length you should aim for; still, the SEO world is full of misconceptions like “ Longer content ranks better” and “your copy should be over 2,000 characters long to rank in top 10”. These assumptions do have their ground, but it’s important to understand that the elusive “ideal content length” may vary a lot from niche to niche. For a realistic reference on the right size of the page’s HTML, it’s best to look at the pages that already rank well for the keywords you’re targeting.

How to check In WebSite Auditor’s Page Audit dashboard, look at Word count in body. When analyzing your page, WebSite Auditor also looked at the top 10 ranking pages for the keyword you specified, and determined an optimal word count range for your page’s content based on this data. If your page’s content falls within this range, you’ll see a green Correct sign next to this factor.
How to improve If your page’s content length is outside the recommended limits, you can edit it right in WebSite Auditor’s Content Editor module. As you type, keep an eye on the Word count in body factor on the left so you can tell when you’ve reached the recommended word count. When you’re done editing, hit Save page to save the newly optimized version of your page to your hard drive, ready for upload.
User Experience & Trust

6. Click-through rate (11%)

A click-through rate, or CTR, is a ratio of the number of times a given search listing was clicked on to the number of times it was displayed to searchers. Numerous patents filed by Google along imply that **SERP click-through rates can have a massive impact on rankings.** SearchMetrics’ ranking factors study even found that CTR has the highest correlation with rankings out of all factors examined.

True, correlation doesn’t always equal causation. But with real-life experiments showing that an increase in CTR can literally boost a site’s rank in real time, it's more than likely that Google uses click-through rate as a factor in its ranking algo.

For every query, Google expects a CTR in a certain range for each of the listings (e.g. for branded keywords, the CTR of No.1 result is around 50%; for non-branded queries, the top result gets around 33% of clicks). If a given listing gets a CTR that is seriously above (or below) that range, Google can re-rank the result accordingly.

**How to check**

The first thing you’d want to do is check your snippets’ current click-through rates. To do that, log in to Google Search Console and go to the Search Analytics report. Select Clicks, Impressions, CTR, and Position to be displayed.

<table>
<thead>
<tr>
<th>Clicks</th>
<th>Impressions</th>
<th>CTR</th>
<th>Position</th>
</tr>
</thead>
<tbody>
<tr>
<td>123</td>
<td>509</td>
<td>24.17%</td>
<td>1.0</td>
</tr>
<tr>
<td>75</td>
<td>96</td>
<td>78.13%</td>
<td>1.0</td>
</tr>
<tr>
<td>66</td>
<td>491</td>
<td>13.44%</td>
<td>1.0</td>
</tr>
<tr>
<td>42</td>
<td>45</td>
<td>93.33%</td>
<td>1.0</td>
</tr>
<tr>
<td>42</td>
<td>597</td>
<td>7.04%</td>
<td>1.0</td>
</tr>
<tr>
<td>42</td>
<td>51</td>
<td>82.35%</td>
<td>1.0</td>
</tr>
</tbody>
</table>

While CTR values for different positions in Google SERPs can vary depending on the type of the query, on average, you can expect at least 30% of clicks for a No.1 result, 15% for a No.2 result, and 10% for a No.3 result.

If the CTR for some of your listings is seriously below these averages, these could be the problem listings you’d want to focus on in the first place.
First and foremost, do not try to artificially inflate your listing’s CTR (such as by using bots to manipulate clicks). Google’s very good at detecting such behavior, and uses safeguards so that no spam and noise get in the way.

**How to improve** So the only efficient way to make your listing earn actual clicks from real users is to make it appealing and click-worthy. You can edit and preview your Google snippet in *Content Analysis > Content Editor* in WebSite Auditor, under the *Title & Meta tags* tab.

As you compose your title and description, make sure they clearly communicate the value of clicking through your page to searchers. If appropriate, use a call to action and instead of simply describing what your page is about, address the searcher directly, and inform them about the benefits of navigating to your page, choosing your product, and so on.

Once you’re happy with your snippet, hit *Save page* to save the upload-ready HTML file to your hard drive.

**7. Social signals (7%)**

The discussion on whether or not social signals affect rankings directly is ongoing, but multiple real-life experiments prove that pages with more social shares rank better. SearchMetrics’ study also found that Facebook, Pinterest, Twitter, and Google+ mentions strongly correlate with search engine rankings.
How to check  In your WebSite Auditor project, go to the Social media tab for social share counts for every page of your site, including Facebook popularity, Google +1s, LinkedIn shares, Pinterest pins, and more.

How to improve  The very first thing to do to make your content shareable in the first place is, of course, adding the social media buttons to your page. For WordPress sites, there’s a selection of ready-made plugins available that let you do just that. For sites that don’t use a CMS, you can get ready-made HTML code for the social buttons here.

Now that you’ve got the necessary prerequisites in place, you’ve got to think about distributing your content for maximum exposure. Whatever your promotion strategy is (email marketing, social media marketing, or influencer outreach), remember that you need content that is truly unique and useful to be successful. If you’re only starting out at social media, here’s a great guide on social content promotion that can also help SEO and brand awareness.
Technical SEO factors

8. Mobile friendliness (12%)

Over a month ago, the news broke that Google's starting the “mobile-first indexing of the Web”, meaning that they are beginning to index the mobile version of websites, when available, as opposed to the desktop version. The less obvious — but perhaps even more important — implication of this change is that Google will now also analyze mobile pages against the ranking signals to determine how a site should rank in both mobile and desktop search results.

If you think about it, it makes sense. Google's previously said that over half of search queries globally come from mobile devices. From a nice-to-have, mobile friendliness has turned into a must - if your page isn't optimized for mobile devices, it's likely to be discarded from mobile search results completely. If you already have a mobile page, then you should focus even more on improving it in 2017 than ever before.

How to check

To check if your page passes Google's mobile friendly test, go to Content Analysis > Page Audit in WebSite Auditor. Locate Page usability (Mobile) on the list of on-page factors on the left. Clicking on Mobile friendly will show you what your page looks like on mobile devices.

The factors in the Page usability (Mobile) section are the exact features Google believes mobile-friendly pages should have, according to Google Developers' PageSpeed Insights, so you'll want all of them to be marked with a green Correct sign.
How to improve If your page is mobile friendly overall, but some factors under Page usability (Mobile) are not marked with a green Correct sign, click on each of those for a detailed description and how-to-fix advice. Whichever factor you're looking at, you'll get straightforward steps on tackling the issue quickly.

If your page isn't mobile friendly altogether, there isn't a better time to optimize for mobile than now. While there's a bunch of options available, responsive design is perhaps the simplest and most widely used solution – and it's the one Google recommends, too. If you use WordPress (or any CMS, really), choosing a responsive template for your site is about all it takes.

You're in for more work if your site is HTML-coded with no CMS in place. However, there's a bunch of documentation available on adapting responsive design for web developers. It might take a bit of work to get every aspect right, but it's an investment that'll definitely keep paying off increasingly.

9. Page speed (7%)

Google has officially confirmed that it uses page speed in its ranking algorithm. Page speed can also influence your SEO indirectly, as search engines will likely crawl fewer pages if your site is slow due to the allocated crawl budget. This, in turn, could negatively affect your site's indexation. Load time can have a massive impact on user experience, too. Slower pages tend to have higher bounce rates and lower average time on page. Research shows a 1-second delay in page load time can result in a 7% reduction in conversions.

So what's the page speed you should aim for? Google's mentioned they expect pages to load in 2 seconds or less. The most common culprit for slow pages is an abundance of uncompressed content on the page, such as scripts, images, or CSS files.

How to check In WebSite Auditor's Content Analysis module, switch to the Technical factors tab and take a look at the Page speed (Desktop) factors on the left. Under this section, you'll see the exact list of speed-related factors Google's looking for in webpages, according to their PageSpeed Insights.
How to improve You’d want to concentrate on any factor under the Page speed section that has an Error or Warning status. The ones with an Info status have less weight but offer room for improvement, too. Click on any of the factors you’d like to improve on for how-to-fix tips.

If there’re any Uncompressed images or Unminified resources found on your page, jump to the Recommendation tab for a ready-made compressed version of these resources. Follow the link to download the lighter version of those, and feel free to upload them to your site right away.
One last thing...

Obviously, the best way to understand which of the signals above are making the biggest impact in your niche is to try them yourself and track progress. One great way of doing that is using SEO PowerSuite's Rank Tracker to monitor your Google rankings, and document the SEO changes you make with Rank Tracker's Events. To do that, open your Rank Tracker project. Go to Preferences > Events and click Add. Briefly describe the event and set a date for it. On the progress graph in Rank Tracker, you will now easily see how your SEO changes are affecting your rankings, and which ones have bigger impact than others.